Veracity Q&A home login about faq

First, I can successfully run:

vv serve --port 8888

And visit "127.0.0.1:8888" to use the web interface on Ubuntu.


Second, I was trying to start the Veracity server when Ubuntu starts using these steps:

http://www.ubuntu-howto.info/howto/how-to-execute-a-command-program-or-script-at-startup-init-mini-howto

Where my /etc/init.d/vvserve script contains:

#! /bin/sh
vv serve --port 8888

But when I restart Ubuntu and visit "127.0.0.1:8888", I am redirected to the following page:

alt text

Any repository URL I visit or select in the menu, also redirects me to the same page. So, the server is running but something is not configured properly?

asked Feb 15 '12 at 13:52

Jace%20Browning's gravatar image

Jace Browning
1.8k567082

edited Feb 15 '12 at 17:41

Joe%20Ream's gravatar image

Joe Ream ♦
596514

Seems every time I upload an image, it fails to load on this site.

(Feb 15 '12 at 17:25) Jace Browning
1

Sorry about the images. This site gets a little confused when it auto-generates the URL, and I've logged a bug to fix that. (URL gets generated as /upfiles/image.xyz but the correct URL should be /qa/upfiles/image.xyz)

(Feb 15 '12 at 18:08) Joe Ream ♦

Add the following to the end of your ~/.profile file:

vv serve &

Or specify port and run publicly:

vv serve --public --port 8888 &
link

answered Feb 16 '12 at 08:16

Jace%20Browning's gravatar image

Jace Browning
1.8k567082

This would work, but requires you to log in. The advantage of the init.d script is that it will run if the computer is turned on, even if you don't log in. (I don't have any experience with init.d so i can't really say more about how it might work.)

(Feb 16 '12 at 09:21) PaulE ♦

@PaulE, I understand the limitations. My goal (at the moment) is to allow each developer to launch the web interface once logged in without running a separate command.

(Feb 16 '12 at 09:35) Jace Browning

I guess it's true that without using the --public option, the server would be pretty pointless without being logged in :-) This is probably is the right solution for automatically having the web ui available locally while logged in.

(Feb 16 '12 at 09:52) PaulE ♦

I'm not an expert on this, but it looks like you're seeing a "clean" web environment with no repositories. 'vv serve' expects .sgcloset to be in its home directory. With it running as a startup process, I suspect that it's not running under your user account, where your repos are kept. If you're seeing repos in the drop-down menu, that may be coming from a cookie left over from a prior session.

link

answered Feb 15 '12 at 18:22

Joe%20Ream's gravatar image

Joe Ream ♦
596514

Maybe I should try to start the server from "~/.profile"?

(Feb 15 '12 at 21:36) Jace Browning

Yeah, that would probably be best. That way you'll avoid any potential (likely?) permissions issues as well.

vv serve --port 8888 &

(add "-P" if you want external access)

(Feb 15 '12 at 23:39) Joe Ream ♦

If you want your server to be running for any user, i.e. if you want to stick to the init.d script, you could consider changing your SGCLOSET location. In addition you perhaps should run the vv serve script as a different user that has the necessary permissions.

link

answered Feb 16 '12 at 02:03

Arne%20Mertz's gravatar image

Arne Mertz
698192635

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or __italic__
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×31
×11

Asked: Feb 15 '12 at 13:52

Seen: 1,637 times

Last updated: Feb 16 '12 at 09:52

powered by OSQA